choose language

Deutsch Français 日本語 简体中文

The Health Mate app is compatible with Android devices running Android 4 or higher.

Individual Nokia digital health products may have different compatibility requirements. Please see the Compatibility article of the product you are interested in to confirm your Android device will be compatible.

 

Was this article helpful?

Didn't find what you need? Here's how to get in touch.

Contact us