choose language

Deutsch Français 日本語 简体中文

Compatible devices

  • iPhone 3GS and higher
  • iPad 1 and higher
  • iPad Mini and higher
  • iPod Touch 3rd generation and higher

 

Compatible OS

  • iOS 5 and higher
Was this article helpful?

Didn't find what you need? Here's how to get in touch.

Contact us