choose language

Deutsch Français 日本語 简体中文

Compatible Devices

  • iPhone 4s or higher
  • iPod Touch 5th Gen or higher
  • iPad (2nd Gen or higher, as well as any iPad Mini)
  • Bluetooth Low Energy compatible Android device

Compatible OS

  • iOS 8 (or higher) 
  • Android 5.0 (or higher)
Was this article helpful?

Didn't find what you need? Here's how to get in touch.

Contact us