My BPM Connect will not charge

BPM Connect
Completed

Comments

  • Official comments from Withings
    Armelle

    Hi Henrik,

     

    Thanks for posting. Could you please try charging your BPM Connect for two hours with a different micro-USB cable and a different USB port? After that, I invite you to disconnect your BPM from the charging cable and press the button once. If it does not power on, press and hold the button for 3 seconds to see if it now powers on. If it's the case, you can now attempt to take a measurement with your monitor.

     

    If your BPM Connect is still not charging after performing these steps, I invite you to email us via http://within.gs/help. In your email, please indicate the troubleshooting steps you've already followed and join a video which shows what occurs:

    1) While the monitor is plugged in to charge.
    2) While disconnecting the monitor from the charging cable.
    3) When pressing the button on the monitor.

    Please make sure that the display of your BPM Connect is visible in the video.

     

    Have a great day,

     

    Armelle, Withings Customer Service

  • hstampe
    1

    likes

    Hi, 

    I have already been in contact with your customer service - request #1890435 - Rech has handled it already. I tried all the above you suggested, - but unfortunately nothing helped. 

    You recently released a software update, - maybe that could be a reason and you may have similar requests from other users. 

    Thank you for great service, - much appreciated!

    1

    likes

  • marciaderricks
    0

    likes

    My BPM Connect will not charge. I have followed the instructions above and it still isn't working. I had not used my machine in couple weeks and when I tried to the battery would not charge.  I just need to know how to get my battery working. I charged it last night for 7 hours and it was still dead this morning. Today I charged for 4 hours using a different charging cable and port and nothing happened. 

     

    0

    likes

  • stefan_buchkremer
    0

    likes

    Same here. Tried several cables and ports for days but nothing helps. Always shows empty battery and red.

    Software version is 841 and it cannot be updated as the low battery seems to block that.

    Is there a chance to solve this or replace the battery or is my device basically garbage now?

    0

    likes

Leave a comment as