choose language

Deutsch Français 日本語 简体中文

Withings steel hr not charging

0

Comments

6 comments

Please sign in to leave a comment.

  • Official comment
    Avatar
    Armelle

    Dear Community, 

     

    Thank you for your post. I’m sorry that some of you can’t charge their Steel HR/Sport. For those who haven’t done it until now, please visit this article:

    - Steel HR / Steel HR Sport - Charging my watch

     

    Please make sure that:

    1) The protective film from the factory that is on the backside of the watch has been removed.

    2) The charger is making proper contact with the watch. You should feel a slight magnetic pull when holding the charger on the watch. Also, the cable should stick out in the opposite direction of the Steel HR's button (you’ll find a picture of how to properly charge the watch in the article above).

     

    Here’s what you can also do:

    1) Wash your Steel HR/Sport using warm, soapy water (hand soap only, no other chemicals) and then dry it.

    2) Clean the charger's contacts with a cotton swab moistened with rubbing alcohol and then dry it.

    3) Reboot your watch by pressing and holding the button on its side for 20 seconds. The watch will show “Hello!” once it has reset.

    4) Once done, charge the watch for 12 hours. 

    5) If the situation persists, plug the charger into a different USB port and charge the watch for 12 hours again.

     

    If your Steel HR/Sport is still not charging, I invite you to contact us via https://within.gs/help.

     

    Happy posting,

     

    Armelle, Withings Customer Service

    Comment actions Permalink
  • Avatar
    Ichigo

     Did you check the backside of the watch if the protective film that comes with the watch has been removed? 

    You can try also to clean the battery contact of the watch and charger. If the issue persists, I suggest you contact them at https://within.gs/help so they can help you. 

     

    0
    Comment actions Permalink
  • Avatar
    martin.wild4

    My brilliant Steel HR 40mm has suddenly gone dark, no movement, no display, won't charge even after 12 hours on the charger. nothing on the iPhone app, can you advise best course of action please.  Not been dropped or anything unexpected, simply gone to sleep completely.  I cannot tell you the level of charge beforehand but even if the charge had gone completely I would expect it to awaken after 12 hours on the charger.

    0
    Comment actions Permalink
  • Avatar
    prw.web

    This is the first time I am charging my brand new Steel HR Sport. No indication at all as to whether or not it is charging. Been on for 15 minutes, still at 72%.

    In 15 minutes, my old Garmin Vivoactive 3 would have been at 100%.

    Is this watch THAT slow to charge, or is my charger just not working?

    0
    Comment actions Permalink
  • Avatar
    jmartyn

    I have just received my order of  Steel Sport having paid DHL a further £55 for duty!

    The watch doesn't charge and just shows a big X and no charge icon comes up.

    The instructions are hopeless too.

    Have I made a massive error buying this rubbish?

    0
    Comment actions Permalink
  • Avatar
    wlr0309

    I'm not sure which step did the trick, but I got my watch (Steel HR) working again! I had the watch packed in the box while I did some moving and when I came back/switched back to the Steel HR, the screen was showing '0% Battery.' I charged for days, did the factory reset multiple times, but nothing worked. I read through several of these forums concerning the issue I was having. 

    I started by purchasing a new charging block. I read on the Withings website that the charging cable needed to be 60mA at minimum. I thought, perhaps getting the charging blocks mixed up during the move was the problem. Well, there was no difference yesterday, the screen still showed 0%. I woke this morning and the screen showed 0%. Upon messing with it, the screen would toggle between an X and a picture of the bluetooth sign in a phone. 

    This is what I did . . . 

    There was a forum that said you needed to disconnect and reconnect the bluetooth. I went into the Healthmate app and clicked "Dissociate this Product".

    If you can get your watch to display Factory Reset, I discovered that you can toggle through and set the phone to Demo mode. I set the watch to demo mode. Well, then I could not figure out how to exit demo mode. I read a forum to hold down the button. It was in this time when I couldn't exit demo mode, that I realized, "Oh, I bet I was suppose to disconnect the watch from my phone bluetooth and not the Healthmate app!" I went to my phone settings and clicked "Forget Device". Then I tried to re-establish the bluetooth connecting, it could not find the watch. I went back to trying to exit demo mode, held down the button for 10+ seconds and it would go back to the Jea 1(which I assumed was January 1, for some other language). I think I tried this maybe three times and then MAGIC happened!! The screen toggled to the HR, pedometer, etc settings . . . and I got excited, but it was in demo mode. Still, I had not been able to get to or see those functions/screens for more than four days while I had been trying to fix this watch. I think I did what was needed to exit demo mode. I went back to my phone bluetooth settings and BAM . . . it connected the device!!! I went to the Healthmate app and added my device. It actually pulled up my old/past info, weight, sleep info! I was excited because I thought it would be gone after I dissociated the device. 

    Anyways, once my phone and watch were bluetooth connected, the hands on my watch moved to the correct time and I knew I had made progress. 

    When I tell you, I am so happy, I mean it. I just ordered a new watch last night (I purchased mine in 2019 so its out of warranty). I ordered replacement batteries from amazon to be delivered in two days, and I bought that charging block yesterday evening. 

    I don't know what did the trick, but I really hope this helps! I read through all these related forums and there was no solution. I hope this will help someone get their watch functioning again. 

    0
    Comment actions Permalink
0

Didn't find what you were looking for?

New post
To preserve the Withings Forum as a place of kindness, mutual support, and interest for the products and services provided by Withings, I am committed to:
  • Be courteous and participate in the community with a spirit of friendliness and understanding
  • Respect all users on the forum
  • Avoid controversy or quarrel
  • Ensure that my messages do not infringe on the rights, reputation, image, or privacy of others
  • Avoid any and all discussions which contain insulting or discriminatory comments
  • Abide by the full terms and conditions outlined here

If you need assistance because of an issue which would not be resolved through troubleshooting, such as a product with physical damage, please contact our Support Team.