choose language

Deutsch Français 日本語 简体中文

Can't even tell if my attempts to submit a help request are working




Please sign in to leave a comment.

  • Avatar

    This post is now sort of moot because after trying a few more times, submission of my support request suddenly worked (I got a clear thanks for your submission message).  However, I have no idea why it suddenly worked, so I'm still interested in what difficulties others have had with support request submission.

    Comment actions Permalink
  • Avatar

    same problem!

    Also "send an email" button doesn't work!!!!!!!!!!!!


    Comment actions Permalink

Didn't find what you were looking for?

New post
To preserve the Withings Forum as a place of kindness, mutual support, and interest for the products and services provided by Withings, I am committed to:
  • Be courteous and participate in the community with a spirit of friendliness and understanding
  • Respect all users on the forum
  • Avoid controversy or quarrel
  • Ensure that my messages do not infringe on the rights, reputation, image, or privacy of others
  • Avoid any and all discussions which contain insulting or discriminatory comments
  • Abide by the full terms and conditions outlined here

If you need assistance because of an issue which would not be resolved through troubleshooting, such as a product with physical damage, please contact our Support Team.