choose language

Deutsch Français 日本語 简体中文

Cannot charge

1

Comments

2 comments

Please sign in to leave a comment.

  • Avatar
    klaus.wk

    How long have you been trying to charge it? ceep it in charge for a longer period or try another power source fex an usb port on the laptop. check the contacts on the watch, maybe they are bit dirty.

    0
    Comment actions Permalink
  • Avatar
    mareemizon

    Unfortunately - this happened to me as well.  The first charge worked and now this month, nothing.  Have tried several different ports, cleaning the pins on the charger and the phone - zero.  The charger is also getting VERY hot which is worrying.  I have called Withings support and they suggested I leave it on the charger for 4 hours uninterrupted... I'll see how this goes. Not happy at this stage.

    0
    Comment actions Permalink
1

Didn't find what you were looking for?

New post
To preserve the Withings Forum as a place of kindness, mutual support, and interest for the products and services provided by Withings, I am committed to:
  • Be courteous and participate in the community with a spirit of friendliness and understanding
  • Respect all users on the forum
  • Avoid controversy or quarrel
  • Ensure that my messages do not infringe on the rights, reputation, image, or privacy of others
  • Avoid any and all discussions which contain insulting or discriminatory comments
  • Abide by the full terms and conditions outlined here

Note that this community is supported by its members, not the Withings Support Team.

If you need assistance because of an issue which would not be resolved through troubleshooting, such as a product with physical damage, please contact our Support Team.