choose language

Deutsch Français 日本語 简体中文

Can not connect to TrainingPeaks




Please sign in to leave a comment.

  • Avatar

    Have you tried connecting Withings to TrainingPeaks using a private browser? If yes and you're still unable to connect it, it will be better to get help from the support team at

    Comment actions Permalink
  • Avatar

    Thanks Zanes, yes I have. Actually my Firefox browser is set to private only and I just verified that and tried to reconnect. Guess I will move on the support.

    Comment actions Permalink

Didn't find what you were looking for?

New post
To preserve the Withings Forum as a place of kindness, mutual support, and interest for the products and services provided by Withings, I am committed to:
  • Be courteous and participate in the community with a spirit of friendliness and understanding
  • Respect all users on the forum
  • Avoid controversy or quarrel
  • Ensure that my messages do not infringe on the rights, reputation, image, or privacy of others
  • Avoid any and all discussions which contain insulting or discriminatory comments
  • Abide by the full terms and conditions outlined here

Note that this community is supported by its members, not the Withings Support Team.

If you need assistance because of an issue which would not be resolved through troubleshooting, such as a product with physical damage, please contact our Support Team.